
Encom ModelVision Pro

This release of Encom ModelVision Pro has many new features including joined

polygons, FFT grid filters, colour table editor, IGRF utilities, and new conversion

utilities, as well as many repairs and enhancements.

CD upgrade

A CD upgrade is available for users with current Support and Updates service
subscriptions.

CD installation

To install ModelVision Pro 7.0 from CD, read the installation notes which can be found
on the inside front cover of the CD.

Website download instructions

A complete installation of ModelVision Pro is shipping now and is available from the
Encom website. Go to www.encom.com.au, select the Downloads option and from there
select ModelVision Pro. The file size is approximately 55Mb.

The web download installation includes software, User Guide and Reference Manual
files, tutorials and example data.

Once installation of the software is complete, ModelVision Pro 7.0 will require an update
to your licensing. Please use the File>Licence option to access the Licence Manager. If
you are upgrading ModelVision Pro from a previous operational version, you are granted
20 days to update the licence.

Note: The installation of ModelVision Pro 7.0 by default is installed into a folder called
\ENCOM\MVIS_PRO 7.0. This means that the upgrade software will not overwrite any
previous version of ModelVision Pro.

Version 7.0 Release Notes

Polygroup Body

This new body type allows you to create
complex 3D models using grouped
polygonal sections. It replaces the previous
snap function and provides a fast, elegant
way for managing complex earth models
where you need to model the whole
subsurface rather than the anomalous
regions.

Major features include:

• Linked vertices to prevent overlap/gaps
between adjacent bodies

• Links maintained during reshape, block
shift and inversion of models

• Automatic digitising of new bodies to
edges of existing bodies

• Bodies are grouped together in a
section to form a polygroup

• All polygons in the polygroup have the
same azimuth and strike length

• Links maintained during inversion of
models

• Model full geological sections

• Model complex basement geology

• Model multiple mine cross-sections

• Detach individual bodies from
polygroup if necessary

You start with a single polygon and attach
new polygons using the new auto-snap
function. This feature is easy to use,
provides an audible feedback click with
each snap and has an edge following
capability that makes the creation of
abutting polygons very fast. A right mouse
click undoes the last point.

The polygroup body is created on a
section and multiple sections can be used
to allow for magnetic and density changes
that are perpendicular to the line of
section. This feature allows full 3D
modelling of sedimentary basins over
steeply dipping basement geology. You can
see a ghost of the adjacent section on the
current section for use as a reference when
editing the current section.

See Tutorial 9 in the ModelVision Pro
distribution CD for details on how to use
the new polygroup model.

Inversion is supported for polygroup
bodies where points that are common to
two adjacent polygons are moved jointly
during the inversion.

Example of complex basement geology using multiple

sections

The example above illustrates how the
shape of a basement magnetic model can
be modified progressively from one section
to the next. In a joint magnetic and gravity
modeling exercise, you can add
sedimentary sections above the basement
surface and perform joint magnetic and
gravity modelling. The model above is
illustrative only but shows how you can
combine polygons within a polygroup to
build a true 3D sedimentary basin and
basement model.



Petroleum Exploration Sections

Gravity modelling and inversion of
sedimentary sections is used widely in
petroleum exploration. The new polygroup
body now makes it much easier to build
cross-sections and full 3D basin models.
The example shown here illustrates the
development of a complex layered model
with two salt diapirs. The linking of
adjacent layers makes it easy to connect to
an existing layer without redrawing.

Assignment of lithology colours and
properties makes it easy to apply
appropriate colour shading techniques to
the geological section.

The salt diapirs truncate the sedimentary
layers and are linked to vertices on the
layers. Salt diapirs can also be stratified to
allow for vertical changes in density. By
using multiple cross-sections,a true 3D
response can be calculated for salt domes
for precision matching against depth
converted seismic sections.

Mine Plan Modelling

When geological sections are available
from developing or production mining
operations, they can be used as controls
for development of magnetic and gravity
models. Each section is modelled using the
backdrop of the geological section as
shown.

Geological section displayed in the cross-section view

By tracing the outline of each geological
feature in the section, the cross-section can
be fully modeled. In many cases it is not
necessary to model every geological unit,
only those with significant density or
magnetic susceptibility contrast. The figure
below shows a central cross-section that
has been created directly from the located
image of the mine section.

Example of the ModelVision Pro model developed from

the detailed geological section

In this San Nicolas example, the
mineralized zone has been modelled on
adjacent lines to show how the deposit
could extend beyond the control.

Once a control model has been
developed, it is then possible to look for
extensions beyond the limits of drilling.
The initial process is focused on balancing
the bulk properties using inversion after
adjusting the regional field. When this
process is complete, you can then look at
unexplained anomalous components in
the field data to see if possible extensions
of the deposit exist beyond the drillhole
control.

Once completed, the model can be
exported to other packages in 3D DXF,
GoCAD and UBC model formats.

Colour Lookup Tables (LUT)

You can now build your own colour
lookup tables for images and body
lithology using Encom’s LUT Editor. This
new tool can be used to create LUTs for ER
Mapper, Oasis montaj™, ArcGIS, MapInfo
and Profile Analyst.

This tool is used with the new lithology
colour type for bodies that extends the
existing unique colour and colour by
property options.

Lithology Colour Coding

Bodies can be assigned user-selected
colours and names using a predefined
lithology lookup table. The LUT Editor can
be used to build your own lithology tables
or you can edit those that are supplied with
ModelVision Pro. The table is normally
selected at the start of a project and used
throughout the project.

You can assign lithologies such as basalt,
diorite, sandstone, shale, siltstone etc.

The colour selector for bodies now
supports more than 16 colours if required.

New Toolbar Buttons

You can now access the IGRF control,
calculator and map lighting from the
toolbar. The IGRF control sets the IGRF
values for modelling and now it can create
grids of IGRF values. The calculator is used
for points, lines, drillholes and grids and
because it is used extensively, we have
added it to the toolbar buttons to make it
easier to find. ModelVision Pro uses an
illumination similar to 3D for models in
map views, but this changes the colour
saturation and can make it difficult to relate
the bodies to the colour lookup table. This
new button allows you to toggle lighting on
and off.



FFT Line Filters

Band Limited Noise Generator

This is a new FFT filter operating on line
data. It allows the user to add noise with a
uniform distribution and a specified
standard deviation in a low pass
bandwidth to an existing data channel. It is
accessed from the Filters>FFT Filters>Band
Limited Noise Generator menu item.

FFT Grid Filters

The research capabilities of ModelVision
Pro have been extended with the
introduction of a comprehensive range of
2D FFT filters that include the following:

• band pass

• high pass

• low pass

• x, y, z component transforms

• upward continuation

• downward continuation

• 1st, 2nd vertical derivative

• fractional derivatives

• x, y horizontal derivatives

• reduction to equator

• reduction to pole

• pseudo-gravity transform

• pseudo-magnetic transform

You can use these filters to transform TMI
data for use with some of the enhanced
inversion capabilities in ModelVision Pro
such as inversion on the first vertical
derivative.  You can use the grid calculator
to create the 2D analytic signal and tilt
filters.

Example of cascaded upward continuation, reduction to

pole and first vertical derivative filters.

DXF to TKM Converter

3D DXF files can be converted into TKM
model files by the DXF2TKM plugin
module. It is available within ModelVision
Pro from the menu Model>Import>DXF–
3D. This module will create a TKM file
which will be loaded automatically into
ModelVision Pro.

This powerful new capability allows you to
introduce complex models from other
products and simulate their magnetic and
gravity responses.

IGRF Utilities

The existing IGRF Calculator is used for
calculating the Earth’s geomagnetic field at
any point on a chosen map and for setting
that as the inducing field for modelling.

There is now an IGRF grid creator available
by clicking on the globe icon button on the
toolbar and then the Grid Creator tab. This
allows you to select an area specified by
latitude and longitude limits and a grid
interval to create grids channels of the
Earth’s geomagnetic field intensity,
inclination and declination.

The area is initially set to the limits of the
displayed map but you can drag out a
rectangle to define a region within that map
or edit the actual values to set them
precisely. On clicking OK, new grids
IGRFint, IGRFinc and IGRFdec will be
created for the selected area. These grids
can be displayed in a map view as an
image or contours.

Creating IGRF grids for a selected region

Alternatively, if you have a grid in memory
specified in degrees latitude and longitude,
this grid can be used as a template by
ticking the ‘Set from Grid’ checkbox and
selecting the required grid channel. For
your convenience there is also a link
button from this dialog to the Synthetic
Grid creator.

The advantage of using an existing grid is
that a grid of elevation values can be
supplied, in which case you can clear the
‘Fixed’ checkbox and the IGRF values will
be computed for the elevation of each
individual grid station.

Multiple Body Editing

Editing of multiple bodies is controlled
from the Body Properties Table and allows
you to change certain properties of a
contiguous sequence of bodies. If the
required bodies are not contiguous their
order in the table can be changed using
the “U” or “D” keys on the keyboard.

Setting parameters for several bodies

Body Conversions

A range of body conversions is now
available to increase the modelling
flexibility. We find it useful to perform fast
modelling with the tabular body and then
convert it to a polygon or polyhedron for
refinement of the shape. The body can also
be sliced horizontally into a series of
parallel slices that can be assigned
individual properties. The table overleaf
shows the range of conversions supported
in version 7.0.



Bug fixes and improvements

• Snap to vertex and Sync vertex
buttons have been removed from the
toolbar to avoid confusion with the
polygroup body. A new entry has been
added to the mivision.ini file
([MISCELLANEOUS]SnapButtons). This
defaults to 0 but can be set to 1,2 or 3
in order to display one or both buttons.
The snap function can be used in the
map view to join plunging prism
models.

• Picking bodies has been improved for
the difficult situations where bounding
rectangles of bodies overlap.

• Polyhedron computation problems
which occasionally occurred near
singularities have been substantially
reduced.

• Nulls detection has been improved
reducing the generation of huge
numbers which previously affected
some computations, graphic displays
and AutoMag.

• Muddy images
Bugs in the histogram stretch and
shadow enhancement algorithms have
been corrected which solves the

previously poor (muddy) representa-
tion of certain grids.

• Match Average computation mode has
been disabled when multiple lines are
selected. Previously this option resulted
in different offsets being added to
individual lines.

• BMP And Profile Analyst EGB files
The current folder for these files is now
added to their export file names so that
you can more easily locate them.

• Geosoft GDB line data
The import of this data has been
changed from single to double
precision.

• Maximum entropy padding
The warning messages for padding of
sparse data have been improved.

• Large font settings (120 dpi) on high
resolution screens caused problems
with the truncation of some dialogs.
This occurred with the body property
multi-tab dialog and map rectangle has
been corrected.

• Inversion of prism bodies
A problem restricting the inversion of
prism bodies has been fixed.

• Gridding
The default number of minimum
curvature iterations in gridding has
been changed from 10 to 100.  For
final grid production we recommend
using 500 iterations and twice the line
spacing in the expert setting to get the
optimum results from your grids.

• Mvision.ini
A problem with this configuration file
occasionally disappearing has been
fixed.

• Synthetic line clipping
The inexact clipping of lines in the
synthetic line generator has been
corrected.

• Regionals greater than 4th order were
not stored in session files
The number of coefficients stored in a
session file has been increased up to a
10th order polynomial.
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Body Conversion Table

New Body

Poly Tab Cyl Ellipsoid Sphere P Prism Frustum Pipe Polyhed.

Polygon

Tabular

Cylinder

Ellipsoid

Sphere

P Prism

Frustum

Pipe

Gen Polyhed.

1

1S 1S

1

1

1 1

1S 1S

1S 1S

1nt 1S

1nt 1S 1S

1

1S

1

1

1

1S

1

1

1

Legend:

1 – Conversion enabled

S – Subdivision by layers enabled

nt – Taper of sides will be lost

Notes:

• Dipping top surface of a plunging prism is

only retained for the top layer when a

body is subdivided.

• When a tabular body is converted to a

multi-slice polygon, slices are automati-

cally placed in a polygroup body.

• When subdividing a new body into layers,

variable properties can be assigned as a

function of depth.

For more information

For more information about Encom ModelVision Pro, visit our website at www.encom.com.au, or talk to Encom to arrange a
demonstration or request an evaluation copy of the software. To contact an authorised reseller in your region,
visit www.encom.com.au/resellers

Head Office

Level 1, 123 Walker St
North Sydney
NSW 2060, Australia
Tel +61 2 9957 4117
Fax +61 2 9922 6141

Web

www.encom.com.au

Email

info@encom.com.au


